tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 53088] Give PoolCleaner TimerTask a better name
Date Mon, 23 Apr 2012 13:57:51 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=53088

Filip Hanik <fhanik@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |INVALID

--- Comment #2 from Filip Hanik <fhanik@apache.org> 2012-04-23 13:57:51 UTC ---
I am marking this invalid since
1. Singleton is only a relative term to a classloader. An app that embeds this
library can start up two different pools in two different classloaders
2. The thread, even in a single class loader system can change names - since
the timer thread, while being a singleton, can be stopped, and then started as
pools start and stop throughout the runtime of the JVM.

The name currently helps identify what classloader started it, and what time it
started.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message