tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Lamy (*$^¨%`£) (Updated) (JIRA) <>
Subject [jira] [Updated] (MTOMCAT-140) Allow specifying the classloader to use for loading webapps.
Date Fri, 13 Apr 2012 10:04:13 GMT


Olivier Lamy (*$^¨%`£) updated MTOMCAT-140:

      Component/s: tomcat6
    Fix Version/s: 2.0
> Allow specifying the classloader to use for loading webapps.
> ------------------------------------------------------------
>                 Key: MTOMCAT-140
>                 URL:
>             Project: Apache Tomcat Maven Plugin
>          Issue Type: Improvement
>          Components: tomcat6, tomcat7
>    Affects Versions: 2.0-beta-1
>            Reporter: Leigh Anderson
>            Assignee: Olivier Lamy (*$^¨%`£)
>            Priority: Minor
>             Fix For: 2.0
>         Attachments: loader.patch
> If one uses a context.xml with a <loader> element to specify the class loader implementation
to use with the tomcat7:run goal, this causes Tomcat to override the WebAppLoader carefully
created by the plugin, without the
> benefit of a properly configured class path.
> The attached patch adds a <classLoaderClass> property to configure which class
loader implementation to use. This is probably of limited utility as most classes will be
loaded by the parent classloader anyway. 

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message