tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raphaël Zürcher (Commented) (JIRA) <j...@apache.org>
Subject [jira] [Commented] (MTOMCAT-143) contextFile and tomcatUsers defined in pom.xml are not used with target tomcat7:run
Date Tue, 17 Apr 2012 05:23:24 GMT

    [ https://issues.apache.org/jira/browse/MTOMCAT-143?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13255321#comment-13255321
] 

Raphaël Zürcher commented on MTOMCAT-143:
-----------------------------------------

Here is my configuration in pom.xml :

<plugin>
						<groupId>org.apache.tomcat.maven</groupId>
						<artifactId>tomcat7-maven-plugin</artifactId>
						<version>2.0-SNAPSHOT</version>						
						<configuration>
							<domain>TomcatRunner</domain>
							<port>${app.port}</port>
							<url>/manager</url>
							<path>${app.contexturl}</path>
							<contextFile>${appdir}/context.xml</contextFile>
							<tomcatUsers>${appdir}/tomcat-users.xml</tomcatUsers>
							<useTestClasspath>true</useTestClasspath>
							<contextReloadable>true</contextReloadable>
							<fork>${tomcat.fork}</fork><!-- fork=true will stop tomcat after run
-->
						</configuration>
						<executions>
							<execution>
								<id>tomcat-run</id>
								<phase>pre-integration-test</phase>
								<goals>
									<goal>run-war-only</goal>
								</goals>
							</execution>
							<execution>
								<id>tomcat-shutdown</id>
								<phase>post-integration-test</phase>
								<goals>
									<goal>shutdown</goal>
								</goals>
							</execution>
						</executions>
						<dependencies>
							<dependency><!-- Servler 2.x not compatible with Tomcat 7 -->
								<groupId>javax.servlet</groupId>
								<artifactId>javax.servlet-api</artifactId>
								<version>3.0.1</version>
							</dependency>
							<dependency>
								<groupId>oracle.jdbc</groupId>
								<artifactId>ojdbc6</artifactId>
								<version>${oracle.version}</version>
							</dependency>
						</dependencies>
					</plugin>

Since the middle of the last week, this doesn't work anymore. The definition of my users in
the specified tomcat-users.xml is not used.
                
> contextFile and tomcatUsers defined in pom.xml are not used with target tomcat7:run
> -----------------------------------------------------------------------------------
>
>                 Key: MTOMCAT-143
>                 URL: https://issues.apache.org/jira/browse/MTOMCAT-143
>             Project: Apache Tomcat Maven Plugin
>          Issue Type: Bug
>          Components: tomcat7
>    Affects Versions: 2.0
>         Environment: linux
>            Reporter: Raphaël Zürcher
>            Assignee: Olivier Lamy (*$^¨%`£)
>
> In the configuration of the plugin into my pom.xml, I've defined the path to the contextFile
and the tomcatUsers like this :
> <contextFile>${appdir}/context.xml</contextFile>
> <tomcatUsers>${appdir}/tomcat-users.xml</tomcatUsers>
> It works using version 2.0-beta-1 and worked with 2.0-SNAPSHOT until a few days ago.
Tomcat7 start correctly, but my tomcat-users.xml is not used and I cannot authentied services
deployed on my tomcat. I use this configuration with jenkins for testing.
> Is there a regression in 2.0-SNAPSHOT or a new configuration issue ?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message