tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Costin Manolache <cos...@gmail.com>
Subject Re: Release Tomcat Native 1.1.23
Date Wed, 22 Feb 2012 16:47:15 GMT
On Wed, Feb 22, 2012 at 8:13 AM, Mladen Turk <mturk@apache.org> wrote:

> On 02/22/2012 03:54 PM, Costin Manolache wrote:
>
>> On Tue, Feb 21, 2012 at 11:11 PM, Mladen Turk<mturk@apache.org>  wrote:
>>
>>>
>>>>  Well I personally would not merge that into 1.1.x branch.
>>> It would be a bit weird to have 1.1.22 as is, and 1.1.23 with
>>> whole bunch of new features and API's.
>>> That's not why we introduced branches at the first place.
>>>
>>>
>>>  That's right, I agree.
>>
>>
> OK, so 1.1.x stays as is.
>
>
>
>>  I see no problem with that.
>>> It requires apr-1.4.x so this might be a solution for
>>> that sslext code instead porting that back to 1.1.x
>>>
>>>
>> sslext works best with openssl 1.0.1 beta 2 ( i.e. latest ) - to get npn
>> working with older ssl it needs a patch ( nodejs, chrome do this ).
>> But it compiles and just lacks the npn feature without the patch.
>>
>> So for me a 1.2.x with recent apr and openssl would be best.
>>
>>
> Cool, lets then cleanup the code in trunk and go for 1.2.x
> release after we cut 1.1.23. OK?
> 1.1.x would be in feature freeze state after we release 1.2.x.
>
> I'd like we make 1.2.x mandatory for tomcat8 together with removing
> all the code that checks for missing API.
>
> And finally after APR-2.0 gets released we can create 1.2.x branch
> and make trunk as 2.0.x since with APR-2 abi will change.
>
>
+1

One thing I would appreciate help with: I would like to have an option to
statically link
openssl and apr into the tc-native .so - I mean use openssl.a, apr.a.

The reason is to avoid the system libraries which will probably have the
wrong version.

Right now there is the 'cmake' file in trunk that does this for linux64 -
I'm sure it's not the
right way :-), but couldn't figure how to do it with libtool.

openssl/apr needs to be compiled with 'shared' option - otherwise they
won't have pic/etc -
and libtool seems to pick the .so over .a with all flags I tried ( it did
work if I manually removed the .so).

( or if cmake or any of the other build tools is acceptable - will need to
be made portable. I guess gyp would be easiest since there is already an
openssl build file, but not for apr ).


Costin


>
> Regards
> --
> ^TM
>
> ------------------------------**------------------------------**---------
> To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.**org<dev-unsubscribe@tomcat.apache.org>
> For additional commands, e-mail: dev-help@tomcat.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message