tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mladen Turk <mt...@apache.org>
Subject Re: Native components builds on Gump
Date Fri, 24 Feb 2012 09:31:01 GMT
On 02/24/2012 10:07 AM, Konstantin Kolinko wrote:
> Hi!
>
> Thanks to Stefan Bodewig work to resolve issue with expat
> configuration on Gump,
> APR now builds successfully there, after failing for more than 1 year.
>
> So projects that depend on APR and/or HTTPD now have a chance to be built,
> after being in "Prerequisite Failed" state for long time.
>
> One of such modules is "tomcat-connectors-native" with project
> "jakarta-tomcat-jk-native".
>
> Maybe someone can take a look at what is going on there?
> It is currently failing during make:
>
> http://vmgump.apache.org/gump/public/tomcat-connectors-native/jakarta-tomcat-jk-native/index.html
>
> [[[
> mod_jk.c: In function ___init_ws_service___:
> mod_jk.c:787: error: ___conn_rec___ has no member named ___remote_ip___
> mod_jk.c:788: error: ___conn_rec___ has no member named ___remote_addr___
> mod_jk.c:1104: error: ___conn_rec___ has no member named ___remote_ip___
> mod_jk.c:1104: error: ___conn_rec___ has no member named ___remote_ip___
> make[1]: *** [mod_jk.lo] Error 1
> make[1]: Leaving directory
> `/srv/gump/public/workspace/tomcat-connectors-native/native/apache-2.0'
> make: *** [all-recursive] Error 1

Wrong httpd headers been included.

BTW, not sure if that makes sense at all. It's just one platform
and one webserver. We have much wider targets (same for tomcat-native)


Regards
-- 
^TM

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message