tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: Move to Maven? (WAS: Re: Publishing process for JARs for Maven Central)
Date Fri, 23 Dec 2011 15:58:59 GMT
On 23/12/2011 15:13, Olivier Lamy wrote:
> 2011/12/23 Mark Thomas <markt@apache.org>:
>> On 23/12/2011 12:58, Olivier Lamy wrote:
>>> Hello,
>>>
>>> 2011/12/23 Mark Thomas <markt@apache.org>:
>>>> On 22/12/2011 13:48, Olivier Lamy wrote:
>>>>> In o.a.t.u.m.Registry with changing
>>>>>
>>>>>     private ModelerSource getModelerSource( String type )
>>>>>             throws Exception
>>>>>     {
>>>>>         if( type==null ) type="MbeansDescriptorsDigesterSource";
>>>>>         //if( type.indexOf( "" ) < 0 ) {
>>>>>         if (type.length()>0) {
>>>>>             type="org.apache.tomcat.util.modeler.modules." + type;
>>>>>         }
>>>>>
>>>>>         Class<?> c = Class.forName(type);
>>>>>         ModelerSource ds=(ModelerSource)c.newInstance();
>>>>>         return ds;
>>>>>     }
>>>>>
>>>>> package was never added so CNFE.
>>>>> I wonder what is the need for this test ?

<snip/>

> Ok I miss to explain correctly, the snippet contains change I have
> made to get that working.
> 
> see https://github.com/olamy/tomcat70/commit/3cbc6d910c50a1542075b0a2d68de1dac00f2ac0
> Without this change package was not added so I add some CNFE.

OK. That change looks wrong to me. The original code is what I would
expect. It is odd that it isn't working if all. The class should be
present. Can you debug it and see what type is on entry to that method?
Maybe the .xml descriptor files aren't where they are expected to be.

Mark

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message