tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 51726] configure reports "cannot remove `libtoolT': No such file or directory"
Date Tue, 13 Sep 2011 11:06:56 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=51726

--- Comment #3 from Eiji Takahashi <eijit@apache.org> 2011-09-13 11:06:56 UTC ---
(In reply to comment #2)
> Eiji, does this mean there is a problem with aclocal (I have Debian Squeeze,
> with aclocal 1.11.1), then? Or is is a problem with the use of that tool?
I think there is no problem.

Usually, the config.status script renames the file 'libtoolT' to 'libtool'(line
2106). Or it deletes 'libtoolT'(line 2107).
Therefore, the file named 'libtoolT' doesn't remain after executing the
configure script.
-----snippet of config.status
2106    mv -f "$cfgfile" "$ofile" ||
2107     (rm -f "$ofile" && cp "$cfgfile" "$ofile" && rm -f "$cfgfile")
2108   chmod +x "$ofile"
---

I think that there is any problem if the configure(config.status) doesn't
report that message.
> -----snippet of config.status
> 1487
> 1488     cfgfile="${ofile}T"
> 1489     trap "$RM \"$cfgfile\"; exit 1" 1 2 15
> 1490     $RM "$cfgfile"
> 1491
> 1492     cat <<_LT_EOF >> "$cfgfile"
> 1493 #! $SHELL
> 1494
> ---
>

regards.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message