tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 50734] 400 Bad Request when there are no web applications deployed on Tomcat 6.0.32
Date Fri, 09 Sep 2011 14:06:05 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=50734

Chris <christian.boitel@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|FIXED                       |

--- Comment #6 from Chris <christian.boitel@gmail.com> 2011-09-09 14:06:05 UTC ---
This patch has a side effect in my configuration that uses some technical
valves that will no longer be called if a context does not exist for the
requested URL (for example, my valve was able to report how many requests
failed due to invalid context mapping indicating some kind of hacking or
misconfiguration going on).

As a workaround, i had to declare a dummy ROOT context (pointing to an empty
directory) so that the v

I can understand we want to report a 404 but i consider patch should be plugged
where 400 is reported (not so early) to report 404 only if no host is matching.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message