tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: problem when testing tomcat
Date Sun, 18 Sep 2011 12:43:37 GMT
On 18.09.2011 14:29, tlm6291 wrote:
> Hello:
>     I am new in learning Tomcat.
>  
>     In turn, I download tomcat source code , build it with Apache-Ant , and test it with
JUnit. I use the following commands to build and test Tomcat
>          ant test
>  
>     It seams the test fails as I got the following result:
>          BUILD FAILED
>           E:\work\apache-tomcat-7.0.20-src\build.xml:1063: The following error occurred
while executing this line:
>           E:\work\apache-tomcat-7.0.20-src\build.xml:1125: Some tests completed with
an Error. See E:\work\apache-tomcat-7.0.20-src/output/build/logs for details.
>           Total time: 21 minutes 24 seconds

I suggest to start with the recent version (7.0.21) or with current HEAD
from subversion.

>     Then I found the following tests failed
>            org.apache.tomcat.util.net.TestSsl
>            org.apache.tomcat.util.net.TestCustomSsl

Unusual.

Have a look at the files TEST-org.apache.tomcat.util.net.TestSsl.* and
TEST-org.apache.tomcat.util.net.TestCustomSsl.* in the directory
E:\work\apache-tomcat-7.0.20-src\output\build\logs

>     The following is my test environment:
>           System:   Windows XP sp3
>           JDK:      1.6.0-u21
>           Apache-Ant:    1.8.2
>           Tomcat:   7.0.20
>          
>      My questions are:
>           1. Should all the test had to pass?

Yes, the released versions should pass all tests. Current headrevisions
in subversionmight have a few tests failing, which are in the process of
getting fixed, e.g. right now there is an occasionalfailure of the comet
test, but AFAIK no other test fails.

>           2. What's the use of the java classes in the path of "apache-tomcat-7.0.20-src\test"

They are the unit test classes and helper classes for them.

>           3. Also I had tested Tomcat under JDK-1.7.0,  is Tomcat7.0.20 compatible with
JDK1.7 ?

To out current knowledge yes. Be warned though, that Java 1.7.0 (no
patch level) has bugs which can lead to wrong behaviour of Java
programs. See for instance
https://issues.apache.org/jira/browse/LUCENE-3349.

Rainer

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message