tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 51523] ClassNotFoundException when loading TLD listeners
Date Tue, 19 Jul 2011 13:54:41 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=51523

Alonso <alonso.domin@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|WORKSFORME                  |

--- Comment #2 from Alonso <alonso.domin@gmail.com> 2011-07-19 13:54:41 UTC ---
I should be more specific in my previous post. As you can see at logfile the
exception message is:

java.lang.ClassNotFoundException: 
            net.sf.jasperreports.jsf.config.ConfigurationStartupListener

and the listener definition in TLD is as follows:

<listener>
    <listener-class>
        net.sf.jasperreports.jsf.config.ConfigurationStartupListener
    </listener-class>
</listener>

So, Tomcat 7 is not trimming blanks at the string which has been read from the
TLD file. I think it should be considered as a bug no matter how stricter
Tomcat 7 had become validating the TLD file, since TLD is still valid with or
without those blanks.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message