tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Missing thread name in requestProcessor when handling Async
Date Sun, 10 Jul 2011 13:53:05 GMT
Using an AccessLogValve during the unit tests reveals, that the thread
name in the request processor is often not set when handliung async
requests.

To reproduce run TestAsyncContextImpl for trunk with test.accesslog=true
and have a look at the access log in output/build/logs. The only
requests logged wit a thread name are

127.0.0.1 - - [10/Jul/2011:15:..:.. +0200] "GET /error HTTP/1.1" 500
1332 http-bio-8030-exec-1 8
127.0.0.1 - - [10/Jul/2011:15:..:.. +0200] "GET /error HTTP/1.1" 500
1332 http-nio-8030-exec-1 9
127.0.0.1 - - [10/Jul/2011:15:..:.. +0200] "GET /error HTTP/1.1" 500
1332 http-apr-8030-exec-2 8

All other requests have "null" as the thread name.

The following patch fixes most of the cases, but I'm not sure that it is
the right place to fix it:

http://people.apache.org/~rjung/patches/tomcat-async-threadname.patch

The only entries which still have a null thread name are then:

127.0.0.1 - - [10/Jul/2011:15:..:.. +0200] "GET /async HTTP/1.1" 500 53
null 0
127.0.0.1 - - [10/Jul/2011:15:..:.. +0200] "GET /async HTTP/1.1" 500 53
null 0
127.0.0.1 - - [10/Jul/2011:15:..:.. +0200] "GET /async HTTP/1.1" 500 53
null 0

Regards,

Rainer




---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message