tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Tomcat FIPS mode questions
Date Tue, 28 Jun 2011 18:55:22 GMT
Chris,

I've been reviewing your patches to BZ 50570
(https://issues.apache.org/bugzilla/show_bug.cgi?id=50570) and I have a
few questions.

First, why did you change the name of the init method to initializeAPR?
The method is private and should therefore be safe to re-name, but I was
wondering why you did it. Was it to match the terminateAPR method that
performs the somewhat opposite functions?

In general, patches should change the least amount of code possible, if
for no other reason than they are easier to read and evaluate. There are
a lot of changes in here which only affect the formatting of the code,
etc. and so it's tough going making sure that nothing is changing that
shouldn't be.

I'm going to be adapting your patch to make fewer changes which I'll
re-post back to BZ. If you could verify that it's functionally
equivalent to your patch if would be very helpful. (Or, maybe you could
re-post your own patch that ignores whitespace changes).

Thanks,
-chris


Mime
View raw message