tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 50957] Blocking IO can serve wrong response data
Date Sun, 03 Apr 2011 03:07:29 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=50957

--- Comment #19 from Tim Whittington <timw@apache.org> 2011-04-02 23:07:22 EDT ---
My testing was against 7.0.8 with the BIO connector on CentOS 5.4/x64.
Client was Firefox 4.0 with network.http.pipelining=true enabled in
about:config.
Web app is a fairly complex mixed static/JSP/other dynamic resources app.
To replicate all I have to do is log in and do 30-60 seconds of random 'refresh
'o' doom' - once errors start appearing, many resource loads in Firefox break
(e.g. favicon.ico with wrong image, JS resources where HTML should be etc.)

On the HTTP side of things I was seeing 401 (Bad Request) responses from
Tomcat, and the occasional 505 (Version Not Supported). Looking at SOCKS proxy
and Wireshark traces of the HTTP, I couldn't see anything that Firefox was
doing wrong.

I've tested with r1088179 (post 7.0.12) of trunk, and things appear to be
better - I can't get the UI to break anymore in Firefox - but I'm now seeing no
401 responses and many more 505 responses.

I'm not able to spend much time on this in the next couple of weeks, but I'll
try to drop in a build with some additional tracing into our test system at
some point.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message