tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 50957] Blocking IO can serve wrong response data
Date Fri, 01 Apr 2011 16:16:08 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=50957

--- Comment #15 from Brad Plies <bplies@bulliondirect.com> 2011-04-01 12:16:03 EDT ---
(In reply to comment #14)
> It may be unrelated, but I'm trying to track down a (very) reproducible error
> on one of our products where using Firefox with HTTP pipelining enabled results
> in garbled responses (and a smattering of 401 and 505 responses).
> 
> The user reports of this error went along the lines of seeing JavaScript
> content where HTML responses were expected, images switched etc., which sounds
> similar to this.

Thank you for the report.  

This report certainly matches the primary characteristic of swapped content. 
During my tests I do not recall observing those response codes, but that wasn't
what I was primarily paying attention to anyway.  I was triggering the
condition via rapid browser reloads so perhaps some responses could have had
unusual codes like that and I just missed them.

Can you confirm the Tomcat version and that BIO is used?  Have you tried NIO? 
If it is very reproducible what are the exact conditions that you have
established to trigger it?  Would you be able to provide a "Wireshark trace" as
Mark recommended?

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message