tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 50518] jps.exe and jvisualvm.exe cannot detect tomcat using jdk1.6.0_23
Date Thu, 30 Dec 2010 13:36:06 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=50518

Martin Kuba <makub@ics.muni.cz> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|INVALID                     |

--- Comment #2 from Martin Kuba <makub@ics.muni.cz> 2010-12-30 08:36:00 EST ---
This is a bug. I can confirm that the same happens with Tomcat 6.0.26.

This problem is specific to Tomcat and jdk 1.6.0_23. All other applications I
have tried are reported to jps and jvisualvm without problems. It also works
for Tomcat and jdk 1.6.0_22. Please note that a new JVM version 19.0 was
introduced in 1.6.0_23.

I have tracked down the problem to the fact that both jps and jvisualvm detect
running JVMs by looking into /tmp/hsperfdata_$USER directory, which is created
automatically by all SUN JVMs since JDK 1.4.0_02.  

For some unknown reason the JVM running Tomcat does not create the files in the
/tmp/hsperfdata_$USER directory. Even using -XX:+UsePerfData doesn not help.

This bug prevents monitoring production servers running Tomcat with jvisualvm.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message