tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 50214] New: Tomcat threads caught in "S" state and spiralling out of control
Date Thu, 04 Nov 2010 17:06:16 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=50214

           Summary: Tomcat threads caught in "S" state and spiralling out
                    of control
           Product: Tomcat 6
           Version: 6.0.29
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: critical
          Priority: P2
         Component: Catalina
        AssignedTo: dev@tomcat.apache.org
        ReportedBy: paulm@sitescout.com


Hello,

I'm dealing with a bug that I have seen on a few other posts but to date has no
solution. 

Basically, connections come in to the nodes and periodically hang forever and
cause the thread to spiral out of control. If left untouched they keep
happening until I restart tomcat.

Looks like this on tomcat manager:
 Stage    Time            B Sent    B Recv
 S    11115068 ms    0 KB            0 KB    

Exact behavior is also described in this old thread:
     - http://old.nabble.com/httpd-JK-Tomcat-hung-connections-td10403182.html
             - Mind you we dont use JK -- just standalone tomcat on its own
getting requests from a LB
     - more recently: http://forums.terracotta.org/forums/posts/list/3264.page

First off, let me explain my setup. We run a high performance ad network that
processes & bids on real time bidding information. We run two clusters with two
different ISPs: one on the west coast and one on the east coast. (East coast
one is amazon).

I originally thought this was a bug caused by virtualization since I would only
see this issue on nodes running on the west coast. At the time the east coast
and the west coast shared the exact same setup (same software) but different os
images., We use CentOS on the west and the Amazon Flavor linux distro on east -
both 32bit.

After fighting for weeks with my west coast provider I finally realized it
wasn't them. The tell tale was the fact that I started seeing this issue on
west coast (yesterday) when i launched 64bit instance(only with 64bit does it
occur on east coast now).

Also, to note we were originally running with 6.0.24 and then recently upgraded
all to 6.0.29 and still occurring. I tried yesterday running the 64bit instance
with the APR JNI libs and also still occurs.

We don't use sessions, and there are no errors on any nodes when this happens.
They just block and spiral forever. Luckily this doesn't really affect the
cluster. The node is still able to function normally, however eating all the
CPU.

On the west coast where this has happened for months now (since launching) we
are running 32bit CentOS and I have tried everything including upgrading the
kernel to latest. Up until yesterday I had never seen this issue on the east
coast where it shares _identical_ setup (binaries/java/configuration/db) until
we attempted to run a 64bit node where it was immediately noticed.

Can anyone point me in the right direction ? It's definitely occurring on the
latest version of tomcat 6.

Thanks,
-Paul

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message