tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keiichi Fujino <kfuj...@apache.org>
Subject Re: svn commit: r1005367 - in /tomcat/trunk: java/org/apache/coyote/ajp/AbstractAjpProtocol.java java/org/apache/coyote/ajp/AjpAprProtocol.java java/org/apache/coyote/ajp/AjpProtocol.java webapps/docs/changelog.xml
Date Fri, 08 Oct 2010 07:50:16 GMT
> On 10/07/2010 10:54 AM, kfujino@apache.org wrote:
>>
>> +    /**
>> +     * AJP packet size.
>> +     */
>> +    protected int packetSize = Constants.MAX_PACKET_SIZE;
>> +    public int getPacketSize() { return packetSize; }
>> +    public void setPacketSize(int packetSize) {
>> +        if(packetSize<  Constants.MAX_PACKET_SIZE) {
>> +            this.packetSize = Constants.MAX_PACKET_SIZE;
>> +        } else {
>> +            this.packetSize = packetSize;
>> +        }
>> +    }
>> +
>
> This would make AJP fixed to MAX_PACKET_SIZE
> IMO this should be:
>
>    public void setPacketSize(int packetSize) {
>        if(packetSize < Constants.MIN_PACKET_SIZE) {
>            this.packetSize = Constants.MIN_PACKET_SIZE;
>
> Also, 'if(foo)' -> 'if (foo)'
>
>
>
> Regards
> --
> ^TM
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: dev-help@tomcat.apache.org
>
>

Does it mean to rename MAX_PACKET_SIZE to MIN_PACKET_SIZE ?

-- 
Keiichi.Fujino

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message