tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Damon Green <damon...@gmail.com>
Subject Re: Apache alpha and mod_jk
Date Fri, 15 Oct 2010 16:00:32 GMT
On Fri, Oct 15, 2010 at 4:56 PM, Rainer Jung <rainer.jung@kippdata.de>wrote:

> Hi Damon,
>
>
> On 15.10.2010 16:13, Damon Green wrote:
>
>> Hi Tomcat dev,
>>
>> We have a scenario presently that is causing us some difficulties.
>>
>> Env is SPARC Solaris10, gcc.
>>
>> We wish to use the current alpha build of Apache because it includes
>> new features in mod_cache that we want to use, they are checked into
>> trunk. http://svn.apache.org/viewvc/httpd/httpd/trunk/
>>
>
> Good!
>
>
>  We also wish to use mod_jk to connect to Tomcat.
>>
>
> Even better :)
>
>
>  Our issue is that we cannot get any version of mod_jk to work with this
>> Apache.
>>
>> We have tried the pre-compiled binaries of mod_jk, and tried to
>> compile our own mod_jk. Both scenarios are failing.
>>
>> When we use the pre-compiled binary mod_jk.so provided by the Tomcat
>> connectors.
>>
>>
>> http://archive.apache.org/dist/tomcat/tomcat-connectors/jk/binaries/solaris/jk-1.2.30/sparc/
>>
>> mod_jk-1.2.30-httpd-2.2.X.so
>>
>> bash-3.00# ./apachectl configtest
>> httpd: Syntax error on line 139 of /apps/apache-2.3.8/conf/httpd.conf:
>> Cannot load /apps/apache-2.3.8/modules/mod_jk.so into server: ld.so.1:
>> httpd: fatal: relocation error: file
>> /apps/apache-2.3.8/modules/mod_jk.so: symbol ap_log_error: referenced
>> symbol not found
>> bash-3.00#
>>
>
> That's expected, binaries are not compatible between middle releases.
>
>
>  and when we try to compile mod_jk to work with the Apache it fails with
>> the
>> following errors. This mod_jk compiles fine for Apache 2.2
>>
>
> ...
>
>
>  Is anyone able to shed any light on this issue? Is it likely that we will
>> be
>> able to get mod_jk to work with the latest Apache code?
>>
>
> Yes, one of the macros copied in from Apache to mod_jk changed its meaning,
> that's why the build breaks. It's a known and documented issue and I applied
> the following change to mod_jk right now:
>
> http://svn.apache.org/viewvc?view=revision&revision=1022975
>
> Can you try this patch? I expect it applies cleanly to 1.2.30 also, but
> didn't actually test it. There is still some constness warning, but I hope
> it'll work nevertheless. Any feedback would be helpful.
>
> Thanks for bringing this up!
>
> Regards,
>
> Rainer
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: dev-help@tomcat.apache.org
>
>
Thanks Rainer, were going to try that now. Will report back soon.
Might be Monday now ;)

Regards
Damon.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message