Hi, I have a small web application deployed on Tomcat server and is is working pretty fine, except in one mode. The web application is available through 2 modes of links - one is regular and other is Single Sign On based. Here is the sample directory structure: Tomcat webapps MyApp WEB-INF web.xml jsp myapp.jsp MyApp.war bin logs conf web.xml Deployment Procedure: Stop the server Copy the new war to webapps replacing the old one remove the complete diretcory of MyApp recursively (rm -rf MyApp) start the server Issue: We try both the links of application. The normal one works just fine first time itself. The SSO link shows up the directory listings page of webapps directory showing the MyApp.war and MyApp directory link. Now all we need to workaround this is just stop the server again and then start it. Surprisingly both SSO mode link and normal works totally fine. This is recurring problem. Is there a proper permanent fix to this? Please note the web.xml in Tomcat/conf directory has below default listings true index.html index.htm index.jsp Please note the web.xml in Tomcat/webapps/MyApp/WEB-INF directory has below myapp.jsp The application has only myapp.jsp and none of index.* files myapp.jsp is as below /who.do"> Somehow first time when new war is deployed, old exploded diretcory is deleted and server is started, the Tomcat might not be finding xcard.jsp or the application specific web.xml and hence it is listings the directory based on settings in Tomcat/conf/web.xml Second time however it finds the web.xml and xcard.jsp and hence works. We even tried changing deployment procedure not to delete the exploded directory and rest of steps same. But it does not help either. If we drop the new war while the server is running, it does not take the changes in new war. -- View this message in context: http://old.nabble.com/Tomcat-Web-App---Strange-issue.-Requires-2-restart-for-SSO-mode-to-work-tp29600474p29600474.html Sent from the Tomcat - Dev mailing list archive at Nabble.com. --------------------------------------------------------------------- To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org For additional commands, e-mail: dev-help@tomcat.apache.org