tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 50001] Eclipse source files don't belong in project root.
Date Tue, 28 Sep 2010 12:27:22 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=50001

--- Comment #4 from Wesley <wesley.acheson@gmail.com> 2010-09-28 08:27:17 EDT ---
(In reply to comment #2)
> Your patch seems to be broken (it seems to be missing files from your
> description, and instead of deleting files it's just emptying them).
> 

I've checked the patch file and those files contents are in there but for some
reason eclipse doesn't want to apply the files. Which I find odd.


It appears the reason it didn't work is I first moved the launch templates you
had and then modified them. Its trying to apply the modification to the moved
files rather than moving then applying the modification.  Forgive as I'm not
that used to creating patch files.

The basic changes to the launch files where.

Move to the res/ide-support/eclipse folder. rename to start-tomcat.launch.tpl
and 
stop-tomcat.launch.tpl.


Add in the apache licence and change the following lines. (both launch
templates)  This allows for the project name to be used rather than a
predefined one.

-<listEntry
value="/tomcat-7.0.x/java/org/apache/catalina/startup/Bootstrap.java"/>
+<listEntry
value="/@PROJECT_NAME@/java/org/apache/catalina/startup/Bootstrap.java"/>
-<stringAttribute key="org.eclipse.jdt.launching.PROJECT_ATTR"
value="tomcat-7.0.x"/>
-<stringAttribute key="org.eclipse.jdt.launching.VM_ARGUMENTS"
value="-Dcatalina.home=${project_loc:/tomcat-7.0.x/java/org/apache/catalina/startup/Bootstrap.java}"/>
+<stringAttribute key="org.eclipse.jdt.launching.PROJECT_ATTR"
value="@PROJECT_NAME@"/>
+<stringAttribute key="org.eclipse.jdt.launching.VM_ARGUMENTS"
value="-Dcatalina.home=@TOMCAT_HOME@"/>


> I've moved all the files into res/ide-support/eclipse as suggested, but I
> haven't templated the launch targets - they work fine from the
> ide-support/eclipse dir, and I'm still not sure they're a good idea.

Does anyone know how to fix a patch file like this? The info is all there but
it appears to try to apply the wrong changes.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message