tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 49816] New: Tomcat service goin down randomly with the following message "SEVERE: All threads (200) are currently busy, waiting. Increase maxThreads (200) or check the servlet status"
Date Tue, 24 Aug 2010 14:11:14 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=49816

           Summary: Tomcat service goin down randomly with the following
                    message "SEVERE: All threads (200) are currently busy,
                    waiting. Increase maxThreads (200) or check the
                    servlet status"
           Product: Tomcat 5
           Version: 5.5.0
          Platform: PC
        OS/Version: Windows Server 2003
            Status: NEW
          Severity: critical
          Priority: P2
         Component: Servlet & JSP API
        AssignedTo: dev@tomcat.apache.org
        ReportedBy: whitef@avaya.com


I have an issue where my Tomcat server is going down quite often with the
following message:

Aug 19, 2010 12:03:21 PM org.apache.tomcat.util.threads.ThreadPool logFull
SEVERE: All threads (200) are currently busy, waiting. Increase maxThreads
(200) or check the servlet status
Aug 20, 2010 4:47:20 PM org.apache.coyote.http11.Http11Protocol pause
INFO: Pausing Coyote HTTP/1.1 on http-9602
Aug 20, 2010 4:47:21 PM org.apache.catalina.core.StandardService stop
INFO: Stopping service website
Aug 20, 2010 4:47:21 PM org.apache.coyote.http11.Http11Protocol destroy
INFO: Stopping Coyote HTTP/1.1 on http-9602


The curious thing is My MaxTrheads settings are set to 100 instead 200 as the
snippet says, so I wonder from where Apache is taking this "200" I suppose this
might be a hardcoded message but I need you to confirm that apache is reading
my xml or not.


Server.website.xml

<Connector port="9602" maxThreads="100" maxSpareThreads="50"
minSpareThreads="10"/>  


Please let me know whether you have information about this issue and if there's
any workaround/hotfix/release where I could get this working.

Thanks in advance.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message