tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 49528] HttpServletRequest.isAsyncStarted() returns false when a Runnable is started
Date Mon, 05 Jul 2010 13:06:08 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=49528

Pieter Libin <pieter@emweb.be> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|FIXED                       |

--- Comment #7 from Pieter Libin <pieter@emweb.be> 2010-07-05 09:06:05 EDT ---
(In reply to comment #6)
> (In reply to comment #4)
> > I have reverted the original fix and applied a new fix that fixes the issue
> > described here and still passes the Servlet TCK.
> 
> Thanks for the quick fix! I'll give it a try.

Dear All,

when I run the test case on the latest version of the tomcat trunk,
I get the following output, which looks like the Runnable we try to start is
never executed:

Start async()
Dispatching start()
request.isAsyncStarted()1true
Returning from doGet()

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message