tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 49505] ApplicationHttpRequest.setAttribute doesn't call the wrapper's setAttribute in case of "special" attributes
Date Sat, 26 Jun 2010 11:42:01 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=49505

Mark Thomas <markt@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |INVALID

--- Comment #1 from Mark Thomas <markt@apache.org> 2010-06-26 07:41:56 EDT ---
My reading of the spec is that there is nothing mandating that these attributes
must be set via a call to ServletRequest.setAttribute(). This looks to be one
of those areas where implementations have some flexibility.

Your wrapper should be able to call getAttribute() to determine if these
attributes have been set.

The users list is the best place to get additional help with this.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message