tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: svn commit: r944918 - /tomcat/trunk/java/org/apache/tomcat/util/buf/ByteChunk.java
Date Mon, 17 May 2010 10:59:13 GMT
On 17/05/2010 11:35, Konstantin Kolinko wrote:
> I cannot say for sure what the intended usage of findChar() is.  Given
> that the method was not used, we can remove those find* methods
> (though I do not see much benefit from removing),  but I do not like
> changing its behaviour.

Got it. I saw c[] in the findChars() methods and assumed char[] rather
than looking at the actual type.

I am making use of findChars() so I'd like to keep it (at least in soem
form)

findCharXXX are really bad names for methods that actually find bytes.

Given this is a major version change and that we haven't used the code
internally, I'd be quite happy to change the name of the methods from
findCharXXX to findByteXXX and code them all to use bytes.

The code needs to be cleaned up and now is as good a time as any.

Mark



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message