tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 49017] New: Null Pointer in Logs - Clustered Environment
Date Mon, 29 Mar 2010 14:27:41 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=49017

           Summary: Null Pointer in Logs - Clustered Environment
           Product: Tomcat 6
           Version: unspecified
          Platform: PC
        OS/Version: Windows Server 2003
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Cluster
        AssignedTo: dev@tomcat.apache.org
        ReportedBy: bluenogujj@yahoo.com


We have two tomcat instances[6.0.18] running on 2 boxes.
The OS on both of them is Windows 2003 Server.
They are clustered and fronted by Apache httpd and the configuration is as
below :
<Engine name="Catalina" defaultHost="localhost" jvmRoute="jvm1">

  <Cluster className="org.apache.catalina.ha.tcp.SimpleTcpCluster"
  channelSendOptions="4" clusterName="multiplancluster">

    <Manager className="org.apache.catalina.ha.session.BackupManager"
      expireSessionsOnShutdown="false"
      notifyListenersOnReplication="true"
      mapSendOptions="6"/>

    <Channel className="org.apache.catalina.tribes.group.GroupChannel">
    <Membership className="org.apache.catalina.tribes.membership.McastService"
      address="224.0.0.1"
      port="45564"
      frequency="500"
      dropTime="3000"/>

    <Receiver className="org.apache.catalina.tribes.transport.nio.NioReceiver"
      address="node1"
      port="4000"
      autoBind="100"
      selectorTimeout="5000"
      maxThreads="6"/>

    <Sender
className="org.apache.catalina.tribes.transport.ReplicationTransmitter">
      <Transport
className="org.apache.catalina.tribes.transport.nio.PooledParallelSender"/>
    </Sender>

    <Interceptor
className="org.apache.catalina.tribes.group.interceptors.TcpFailureDetector"/>
    <Interceptor
className="org.apache.catalina.tribes.group.interceptors.MessageDispatch15Interceptor"/>
    <Interceptor
className="org.apache.catalina.tribes.group.interceptors.ThroughputInterceptor"/>
    </Channel>

    <Valve className="org.apache.catalina.ha.tcp.ReplicationValve" />
    <ClusterListener
className="org.apache.catalina.ha.session.ClusterSessionListener"/>
  </Cluster>
  <Realm className="org.apache.catalina.realm.UserDatabaseRealm"
  <Host name="localhost"  appBase="webapps"
    unpackWARs="true" autoDeploy="true"
    xmlValidation="false" xmlNamespaceAware="false">
  </Host>
</Engine>

The above config is similar on both nodes.
Everything appears fine on startup, however when a request is sent to one node
an NullPointerException is thrown on the other node and appears in the logs as
below :
org.apache.catalina.connector.CoyoteAdapter service
SEVERE: An exception or error occurred in the container during the request
processing
java.lang.NullPointerException
        at
org.apache.catalina.ha.tcp.ReplicationValve.invoke(ReplicationValve.java:348)
        at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
        at
org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:767)
        at
org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:697)
        at
org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:889)
        at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690)
        at java.lang.Thread.run(Thread.java:595) <<logs.zip>>

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message