tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Rees <dree...@gmail.com>
Subject Re: HttpSessionActivationListener sessionDidActivate not called on cluster node startup
Date Thu, 18 Feb 2010 04:39:46 GMT
Resending to dev - first two posts to users have netted no response.

I've entered a bug, too:
https://issues.apache.org/bugzilla/show_bug.cgi?id=48717

Any ideas, guys?  Having this work would greatly simplify life for me,
but I've looked at the code a bit and can't figure out why it doesn't
work...

-Dave

On Mon, Feb 8, 2010 at 6:46 PM, David Rees <drees76@gmail.com> wrote:
> Hi,
>
> I've got an application where I need to keep track of all the active
> user sessions.  Using both the HttpSessionActivationListener +
> HttpSessionListener interfaces seemed like an easy way to be able to
> keep track of all sessions.
>
> The issue I've come across is that HttpSessionActivationListener
> sessionDidActivate is not called when a node is started up and joins
> or rejoins the cluster so that node loses track of all the existing
> sessions.
>
> The issue is the same on both Tomcat 6.0.24 and 5.5.28.
>
> Searching the archives seem seem to turn up the same issue (in fact a
> post from me nearly a year ago when I had the same problem but forgot
> about!).
>
> I did find an existing bug report, but it was marked fixed way back in 2005.
>
> https://issues.apache.org/bugzilla/show_bug.cgi?id=35916
>
> I tried the same configuration as posted there, but still got the same results.
>
> Anyone got this working or have any suggestions on how to work around
> this issue?
>
> Thanks
>
> Dave
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message