tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jean-frederic clere <jfcl...@gmail.com>
Subject Re: [tcnative] slight apr and openssl version confusion
Date Tue, 05 Jan 2010 08:11:49 GMT
On 01/04/2010 06:01 PM, Rainer Jung wrote:
> What is the use of the file
> 
>    native/srclib/VERSIONS
> 
> in tcnative?
> 
> Ib the 1.1.x branch it contains the info:
> 
> =========================================
> Use the following version of the libraries
> 
> - APR 1.2.8, http://apr.apache.org
> - OpenSSL 0.9.8e, http://www.openssl.org
> =========================================
> 
> But the build system checks for APR 1.2.1 and OpenSSL >= 0.9.7f in
> native/buildconf and native/build/tcnative.m4.

Additionally the buildconf defaults to apr-1.2.7 located in srclib.
What happens is that buildconf copies files from apr the idea was to
have that information in native/srclib/VERSIONS.
I think the file native/srclib/VERSIONS should be created by configure
and doesn't need to be in repository.

Cheers

Jean-Frederic

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message