tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ma...@apache.org
Subject svn commit: r896892 - in /tomcat/trunk/java/org/apache/jasper: compiler/Validator.java resources/LocalStrings.properties resources/LocalStrings_es.properties
Date Thu, 07 Jan 2010 14:21:32 GMT
Author: markt
Date: Thu Jan  7 14:20:30 2010
New Revision: 896892

URL: http://svn.apache.org/viewvc?rev=896892&view=rev
Log:
Update for JSP 2.2

Modified:
    tomcat/trunk/java/org/apache/jasper/compiler/Validator.java
    tomcat/trunk/java/org/apache/jasper/resources/LocalStrings.properties
    tomcat/trunk/java/org/apache/jasper/resources/LocalStrings_es.properties

Modified: tomcat/trunk/java/org/apache/jasper/compiler/Validator.java
URL: http://svn.apache.org/viewvc/tomcat/trunk/java/org/apache/jasper/compiler/Validator.java?rev=896892&r1=896891&r2=896892&view=diff
==============================================================================
--- tomcat/trunk/java/org/apache/jasper/compiler/Validator.java (original)
+++ tomcat/trunk/java/org/apache/jasper/compiler/Validator.java Thu Jan  7 14:20:30 2010
@@ -518,7 +518,8 @@
         public void visit(Node.JspRoot n) throws JasperException {
             JspUtil.checkAttributes("Jsp:root", n, jspRootAttrs, err);
             String version = n.getTextAttribute("version");
-            if (!version.equals("1.2") && !version.equals("2.0") && !version.equals("2.1"))
{
+            if (!version.equals("1.2") && !version.equals("2.0") &&
+                    !version.equals("2.1") && !version.equals("2.2")) {
                 err.jspError(n, "jsp.error.jsproot.version.invalid", version);
             }
             visitBody(n);

Modified: tomcat/trunk/java/org/apache/jasper/resources/LocalStrings.properties
URL: http://svn.apache.org/viewvc/tomcat/trunk/java/org/apache/jasper/resources/LocalStrings.properties?rev=896892&r1=896891&r2=896892&view=diff
==============================================================================
--- tomcat/trunk/java/org/apache/jasper/resources/LocalStrings.properties (original)
+++ tomcat/trunk/java/org/apache/jasper/resources/LocalStrings.properties Thu Jan  7 14:20:30
2010
@@ -427,7 +427,7 @@
 jsp.error.variable.alias=Both or none of the name-from-attribute and alias attributes must
be specified in a variable directive
 jsp.error.attribute.null_name=Null attribute name
 jsp.error.jsptext.badcontent=\'<\', when appears in the body of <jsp:text>,
must be encapsulated within a CDATA
-jsp.error.jsproot.version.invalid=Invalid version number: \"{0}\", must be \"1.2\", \"2.0\",
or  \"2.1\"
+jsp.error.jsproot.version.invalid=Invalid version number: \"{0}\", must be \"1.2\", \"2.0\",
\"2.1\" or  \"2.2\"
 jsp.error.noFunctionPrefix=The function {0} must be used with a prefix when a default namespace
is not specified
 jsp.error.noFunction=The function {0} cannot be located with the specified prefix
 jsp.error.noFunctionMethod=Method \"{0}\" for function \"{1}\" not found in class \"{2}\"

Modified: tomcat/trunk/java/org/apache/jasper/resources/LocalStrings_es.properties
URL: http://svn.apache.org/viewvc/tomcat/trunk/java/org/apache/jasper/resources/LocalStrings_es.properties?rev=896892&r1=896891&r2=896892&view=diff
==============================================================================
--- tomcat/trunk/java/org/apache/jasper/resources/LocalStrings_es.properties (original)
+++ tomcat/trunk/java/org/apache/jasper/resources/LocalStrings_es.properties Thu Jan  7 14:20:30
2010
@@ -430,7 +430,7 @@
 jsp.error.variable.alias = Ambos atributos o ninguno de name-from-attribute y alias pueden
ser especificados en una directiva variable
 jsp.error.attribute.null_name = Nombre de atributo nulo
 jsp.error.jsptext.badcontent = '<', cuando aparece en el cuerpo de <jsp\:text>,
debe de estar encapsulado dentro de un CDATA
-jsp.error.jsproot.version.invalid = N\u00FAmero incorrecto de versi\u00F3n\: "{0}", debe
de ser "1.2" o "2.0" o "2.1"
+jsp.error.jsproot.version.invalid = N\u00FAmero incorrecto de versi\u00F3n\: "{0}", debe
de ser "1.2" o "2.0" o "2.1" o "2.2"
 jsp.error.noFunctionPrefix = La funci\u00F3n {0} debe de usarse con un prefijo cuando no
se especifica un espacio de nombres por defecto
 jsp.error.noFunction = La funci\u00F3n {0} no puede ser localizada mediante el prefijo especificado
 jsp.error.noFunctionMethod = El m\u00E9todo "{0}" para la funci\u00F3n "{1}" no se pudo hallar
en la clase "{2}"



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message