tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Kolinko <>
Subject Re: svn commit: r892554 - in /tomcat/tc6.0.x/trunk: ./ STATUS.txt java/org/apache/catalina/realm/ webapps/docs/changelog.xml webapps/docs/config/realm.xml
Date Mon, 21 Dec 2009 05:23:16 GMT
2009/12/20 Rainer Jung <>:
> Hi Mark, Konstantin and everyone else,
> On 20.12.2009 03:37, wrote:
>> Add support for a connectionTimeout attribute to the JNDIRealm
> I know I voted fror it, but when going through the commits again I wondered
> whether we should call is connectTimeout instead of connectionTimeout. In
> fact is is a timeout for the connect phase and once the connection is
> established the timeout has no more functionality. connectionTimeout might
> suggest something like an idle timeout or a read timeout or a how long a
> connection can be used thing. Since idle and read timeouts exist in the JDK
> LDAP pool implementation and might be added as future enhancements, it might
> be clearer to name the new attribute "connectTimeout" instead of
> "connectionTimeout".
> Comments?

Oh, so there are
com.sun.jndi.ldap.connect.timeout (this property)

I like the current name, "connectionTimeout".  It looks well among
other connectionXXX attributes there. This configuration attribute is
important, because JNDIRealm supports alternateURL.

>From the language point of view, though I am not UK or US resident, I
think that the current name is better. E.g. from this phrase in the
above mentioned Sun document:
"The value of this property is the string representation of an integer
representing the connection timeout in milliseconds"

I know that there is a precedent of

but there is also

Thus I slightly prefer to keep the current name.

Best regards,
Konstantin Kolinko

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message