tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henri Gomez <henri.go...@gmail.com>
Subject Re: Notice : No more IBM support JK/Tomcat on i5/OS V6R1
Date Wed, 05 Aug 2009 07:55:15 GMT
>> Why did we use unixd_set_global_mutex_perms/ap_unixd_set_global_mutex_perms
>> since both call didn't exist in i5/OS V6R1 and I had to set
>> JK_NEED_SET_MUTEX_PERMS to 0 to have them excluded.
>
> Because otherwise, root created file locking objects are inaccessible to the
> child process running in a restricted security context.
>
> Clear enough?
>
> Perhaps the httpd/apr port is whacked.

Very possibile since the AP_NEED_SET_MUTEX_PERMS is set to 1 but I
couldn't find ap_unixd_set_global_mutex_perms in the various include.

And since IBM didn't profide support anymore for Apache 'modules'
developpers, I think it will be not be easy to get a reply about the
APR 1.2 port on i5/OS.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message