tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 42996] POST with nio connector results in missing variables
Date Thu, 06 Aug 2009 07:16:49 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=42996



--- Comment #31 from Jerome Louvel <jerome.louvel@noelios.com> 2009-08-06 00:16:42 PDT
---
Hi Filip,

If you look at the source code in HelloWorldResource.java, you will see that
"ERROR (2)" is displayed by the PUT method "store()" and not the GET method
"represent()".

The fact that it 'appears' to come after the GET trace in the console is just
an issue with the console as the requests are multi-threaded.

The HTTP GET method invokes the annotated represent() method which returns a
static "hello, world" string.

The HTTP PUT method invokes the annotated store(Representation) method, with
the HTTP entity as a parameter and sets the status to 400 only if the entity is
missing or is empty.

I've looked at the wireshark log but the content seems to be mixed up a little,
so we don't clearly see the order of requests and responses.

Hope this helps,
Jerome

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message