tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 47121] mod_jk 1.2.27 produces "JkWorkersFile only allowed once" on Netware 6.5
Date Tue, 26 May 2009 06:29:50 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=47121





--- Comment #8 from Vladimir Mikhelson <vlad@hollebcons.com>  2009-05-25 23:29:45 PST
---
(In reply to comment #7)

Hi Guenter,

Thank you for detailed comments and for the mod_jk loading logic explanation.

This is what I did.

First, in httpd.conf I commented out the following sections:

1.  LoadModule jk_module modules/mod_jk.nlm

2.  <IfModule mod_jk.c>
       JkWorkersFile "sys:/adminsrv/conf/mod_jk/workers.properties"
       JkLogFile "logs/mod_jk.log"
       JkLogLevel error
    </IfModule>

Then I inserted the block from QFTomcatConnector.conf immediately after section
#1 being commented out by that time, "# LoadModule jk_module
modules/mod_jk.nlm"

<IfModule !mod_jk.c>
   LoadModule jk_module modules/mod_jk.nlm
   JkWorkersFile "sys:/adminsrv/conf/mod_jk/workers.properties"
   JkLogFile "logs/mod_jk.log"
   JkLogLevel error
</IfModule>

It made the trick. I used the NCFs you suggested, did not touch the Tomcat.
Both instances of Apache loaded fine.

I did run into some issues with NDSAUDIT being unable to reload itself in
protected mode, so I ended up rebooting the server, which I still meant to do
as a final test. All loaded well after reboot.

Yes, in fact it IS Novel's configuration issue.  Thank you for helping me to
resolve it.

-Vladimir


PS. Unfortunately I needed to roll mod_jk.nlm back to ver. 1.2.23. Virtual
Office would not start with either 1.2.27 or 1.2.28.

I tried to move the line 'Include "SYS:/qfsearch/WEB-INF/QFSrchApache.conf"' to
the end of http.conf per your recommendation while removing all my
modifications. mod_jk loaded fine either way but VO would not start. As soon as
I restored mod_jk v.1.2.23 VO started immediately.

This is what I received in sys:/apache2/logs/error_log:

[Tue May 26 00:50:22 2009] [warn] module rewrite_module is already loaded,
skipp
ing
[Tue May 26 00:50:22 2009] [warn] module ldap_module is already loaded,
skipping
[Tue May 26 00:50:22 2009] [warn] module auth_ldap_module is already loaded,
ski
pping
[Tue May 26 00:50:22 2009] [notice] LDAP: Built with Novell LDAP SDK
[Tue May 26 00:50:22 2009] [notice] LDAP: SSL support available
[Tue May 26 00:50:22 2009] [notice] LDAP: Built with Novell LDAP SDK
[Tue May 26 00:50:22 2009] [notice] LDAP: SSL support available
[Tue May 26 00:50:26 2009] [notice] Apache/2.0.63 (NETWARE) mod_jk/1.2.28
config
ured -- resuming normal operations
[Tue May 26 00:51:11 2009] [error] [client 69.128.xxx.xxx] File does not exist:
sys:/tomcat/4/webapps/vo/servlet
[Tue May 26 00:51:13 2009] [error] [client 69.128.xxx.xxx] File does not exist:
sys:/tomcat/4/webapps/vo/servlet

These are the respective records form sys:/apache2/logs/access_log:

69.128.xxx.xxx - - [26/May/2009:00:51:11 -0500] "GET
/vo/servlet/portal?render=o
n HTTP/1.1" 404 1127
69.128.xxx.xxx - - [26/May/2009:00:51:13 -0500] "GET
/vo/servlet/portal?render=o
n HTTP/1.1" 404 1127

Do you have any ideas or is it strictly Novell's business?

Thank you,
Vladimir

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message