tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: Going for jk 1.2.28
Date Thu, 05 Mar 2009 10:47:30 GMT
On 05.03.2009 10:38, Mladen Turk wrote:
> Rainer Jung wrote:
>> On 05.03.2009 07:50, Mladen Turk wrote:
>>> Rainer Jung wrote:
>>>>
>>>> Do you want to do the next steps, or should I?
>>>>
>>>
>>> BTW, I'd like that we this time use the common
>>> httpd 2.0 and 2.2 versions for producing the
>>> binaries. For 2.0 I'd suggest 2.0.52 (or 2.0.49)
>>> and for 2.2 version 2.2.3.
>>> For 1.3, 1.3.23 should be fine.
>>>
>>
>> In theory for the platforms which use configure, one should add the
>> --enable-api-compatibility switch to configure. This will activate
>> defines in the mod_jk.c to not use post GA ABI features, even if the
>> httpd you are building against has them. So that's a distribution
>> build switch.
>>
>
> If --enable-api-compatibily works, then the version number in
> binaries is wrong and makes users wonder weather it will work
> on previous versions or not. We should be clear about that thought.

I'm just in the process of clearing up the README files in dev/dist for 
1.2.28 appropriately.

You can use the same feature for your Windows builds, simply define 
API_COMPATIBILITY.

Regards,

Rainer

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message