tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 46478] New: configure in mod_jk 1.2.27 don't find Apache 2.2.11's apxs file with Sun Solaris 8
Date Mon, 05 Jan 2009 15:52:32 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=46478

           Summary: configure in mod_jk 1.2.27 don't find Apache 2.2.11's
                    apxs file with Sun Solaris 8
           Product: Tomcat Connectors
           Version: 1.2.27
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Severity: blocker
          Priority: P2
         Component: mod_jk
        AssignedTo: dev@tomcat.apache.org
        ReportedBy: yannick.leny@atosorigin.com


Created an attachment (id=23085)
 --> (https://issues.apache.org/bugzilla/attachment.cgi?id=23085)
config.log with configure in mod_jk 1.2.7 don't find apxs with Sun Solaris 8

Hello I try to compile mod_jk 1.2.27 with Sun Solaris 8 but I can not because
mod_jk 1.2.27's configure can not find Apache's 2.2.11 apxs binary:

/opt/apache-2.2.11/modules/jdk1.5.0_17/include/solaris

I start to compile with :
cd tomcat-connectors-1.2.27-src/native
CFLAGS="-O3 -mcpu=ultrasparc -mtune=ultrasparc
-I/opt/apache-2.2.11/modules/jdk1.5.0_17/include/solaris
-I/opt/apache-2.2.11/modules/jdk1.5.0_17/include" \
CC=gcc CXX=gcc \
./configure \
--with-apxs=/opt/apache-2.2.11/bin/apxs \
--enable-jni \
--with-java-home=/opt/apache-2.2.11/modules/jdk1.5.0_17 \
--with-java-platform=2
make && make install

This configuration works fine with Redhat Enterprise Linux 4.0 (RHEL4)

I try too with 
--with-apxs=/opt/apache-2.2.11/bin
but it don't work.

Configure error message :
checking build system type... sparc-sun-solaris2.8
checking host system type... sparc-sun-solaris2.8
checking target system type... sparc-sun-solaris2.8
checking for a BSD-compatible install... scripts/build/unix/install-sh -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... no
checking for nawk... nawk
checking whether make sets $(MAKE)... yes
checking for test... /usr/bin/test
checking for rm... /usr/bin/rm
checking for grep... /usr/bin/grep
checking for echo... /usr/bin/echo
checking for sed... /usr/bin/sed
checking for cp... /usr/bin/cp
checking for mkdir... /usr/bin/mkdir
need to check for Perl first, apxs depends on it...
checking for perl... /usr/local/bin/perl
could not find /opt/apache-2.2.11/bin/apxs
configure: error: You must specify a valid --with-apxs path
make: *** No targets specified and no makefile found.  Stop.

And I have a file /opt/apache-2.2.11/bin/apxs that I can execute well.

See config.log added as an attachment.


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message