tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William A. Rowe, Jr." <wr...@rowe-clan.net>
Subject Re: tcnative API stability/compatibility
Date Fri, 02 Jan 2009 16:25:25 GMT
Mark Thomas wrote:
> Rainer Jung wrote:
>> Hi,
>>
>> we now have tcnative 1.1.x and trunk. What's our goal w.r.t. API stability?
> 
> My understanding was that trunk was created to introduce APR 1.3 and
> that the result would be tcnative 1.2.x.

APR 1.3 is abi compatible to 1.2 - although you famously adopt internal
functions which have no API compatibility contract.

If tcnative 1.2 is simply to demand APR 1.3 as a minimum version consuming
some new API's, this make sense, but backporting to tcnative 1.1 would seem
silly.  Keep tcnative 1.2 abi-compatible to tcnative 1.1 (JNI perspective)
and drop 1.1, start shipping 1.2 only.




---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message