tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 37515] smap not generated by JspC when used from Ant for precompilation
Date Sun, 04 Jan 2009 01:21:32 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=37515


Jess Holle <jessh@ptc.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|WONTFIX                     |




--- Comment #10 from Jess Holle <jessh@ptc.com>  2009-01-03 17:21:31 PST ---
The issue with using compile="true" is that it does not give as much control
over compilation.  For starters we use a custom extension to the web app
classloader to introduce another directory to the classpath *before*
WEB-INF/classes.  That's the main item -- we could probably live with just
using compile="true" if we could control the compilation classpath.  We also
use UTF-8 as the encoding for javac, but I believe jspc must do so internally
as well -- as that's what it produces.  [By the way, the documentation should
really make the fact that jspc produces UTF-8 Java sources clear as this is not
the normal default for Java sources or javac.]

I'm re-opening this since there is a use case for compile="false", but I'll
understand if that use case is insufficiently interesting to everyone else (as
we can work around this ourselves as well by not using pre-compiled JSPs when
debugging).


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message