tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject DO NOT REPLY [Bug 46352] Apache 1.3 crashes inside with selfsigned SSL cert
Date Mon, 08 Dec 2008 11:02:37 GMT

Patrick Middleton <> changed:

           What    |Removed                     |Added
             Status|NEW                         |RESOLVED
         Resolution|                            |WORKSFORME

--- Comment #5 from Patrick Middleton <>  2008-12-08 03:02:35 PST
I tried the additional debugging tips (run a single server using -X, as a user,
listening on nonprivileged ports) but still couldn't create a coredump.

I tried the hint about 'JkMountCopy All', and cleaned up my httpd.conf.  There
are no longer mod_jk directives in virtual host containers.  httpd no longer

I'd been using mod_jk directives in virtual host containers because there has
been a problem with static URIs /services.html and servlet-mapped URIs
/services/ and /services/* where neither would work correctly.  Using mod_jk
1.2.27 with JkMountCopy All in the global server configuration, that problem is
gone too.

For https://localhost/services/index.jsp:
mod_jk.c:666 r->subprocess_env: SCRIPT_URL=/services/index.jsp=SCRIPT_URI

For https://localhost/services/:
mod_jk.c:666 r->subprocess_env:

At this point, I think there is a bug in how mod_jk works with virtual hosts,
but which does not affect well-configured servers.  Since I'm making no
progress debugging this and it's not crashing, do we want to close this bug

Configure bugmail:
------- You are receiving this mail because: -------
You are the assignee for the bug.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message