tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 46352] Apache 1.3 crashes inside mod_jk.so with selfsigned SSL cert
Date Fri, 05 Dec 2008 17:16:20 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=46352





--- Comment #3 from Patrick Middleton <patrick@onestep.co.uk>  2008-12-05 09:16:19 PST
---
so we have all the magic tested and working as per
http://developer.apple.com/technotes/tn2004/tn2123.html for enabling core
dumps, and even a CoreDumpDirectory directive in /etc/httpd/httpd.conf , but we
get no core dumps.

One thing I have noticed is that httpd seems to take several seconds to crash;
as if steadily iterating until it blows the stack up, which might explain why
the the dead address looks like a bit of ASCII string.

I have also noted that my JkMount directives aren't working as expected.  Using
older mod_jk versions, they worked with everything in the main httpd.conf ;
with newer versions, some weren't working at all with HTTPS, so I moved most of
the mod_jk configuration into the virtual host containers; and it's still not
right.  Depending on the URL, some requests get 404 errors from the webserver,
and some cause crashes.

mod_jk.c:663 r: 0x01807100 r->subprocess_env: 0x01807468
mod_jk.c:666 r->subprocess_env:
REDIRECT_SCRIPT_URL=/services/=REDIRECT_SCRIPT_URI=http://localhost/services/=REDIRECT_STATUS


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message