tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leon Rosenberg" <rosenberg.l...@googlemail.com>
Subject Re: Tomcat 5.5.25.0 - 100% CPU Utilization
Date Thu, 27 Nov 2008 09:54:33 GMT
Hello,

next time it happens (if it does) make a thread dump (kill -QUIT pid)
and sent it to us.
Usually it helps to find an infinite loop or at least point to the
problem source.
Code review won't help you to find an infinite loop if it for example
results from an unsynchronized hashmap.

regards
Leon

On Thu, Nov 27, 2008 at 10:31 AM, Madan KN <madan.kn@gmail.com> wrote:
> *Hi,*
>
> We are using tomcat with the following system configurations.
>
> Linux 2.6.9-78.0.1.ELsmp (RHEL)
> Quad Core CPU
> Memory 16GB
> Java version 1.5.0_11
> Tomcat Version 5.5.25.0
> CATALINA Heap Size: 1GB
> Running Only 1 Webapp
>
> * Application runs absolutely fine for some days and suddenly starts
> consuming all the 4cpu's to 100%.
> * We have checked all our logs and did through code digging and found
> nothing unusual or any infinite loops or any resource locks or dead locks.
> We even don't have any DB calls from the app.
> * Again after restart the server comes back to normal and works fine.
>
> Any help or insight to the problem could be appreciated.
> *
> Thanks In Advance.*
> Madan KN
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message