tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 46131] for a root context getContextPath returns "/" after a forward
Date Tue, 04 Nov 2008 12:12:11 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=46131


Denny Strietzbaum <denny.strietzbaum@hybris.de> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|INVALID                     |




--- Comment #3 from Denny Strietzbaum <denny.strietzbaum@hybris.de>  2008-11-04 04:12:10
PST ---
Reopened because i've found out more.
The problem only occurs when declare the context within server.xml and
setting the path to "/".

This (correct) context declaration works as expected:
<Context path="" docBase="D:/path/to/docbase" />

Whereas this (not so correct) one produces the decribed issue:
<Context path="/" docBase="D:/path/to/docbase" />

I know it's not a good thing to use the server.xml but unluckily 
i have no influence on that.


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message