tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 46105] New: URIEncoding doesn't affect after form-authentication redirect
Date Tue, 28 Oct 2008 06:37:52 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=46105

           Summary: URIEncoding doesn't affect after form-authentication
                    redirect
           Product: Tomcat 5
           Version: 5.5.27
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: Connector:HTTP
        AssignedTo: dev@tomcat.apache.org
        ReportedBy: kuleshov@org.vrn.ru


How to reproduce bug.

Configure tomcat connector with URIEncoding=UTF-8 attribute.
Make a simple page that write out any request parameter. Configure this page as
protected with form-based authentication.
Try to access page, e.g.

/site/page.jsp?q=%xx%yy%zz%tt

where q=%xx%yy%zz is value in UTF-8 charset.

When page is being accessed for the first time, then after authentication,
parameter "q" is incorrectly interpreted (it seems as it was in ISO8859-1 or
anything else, but not UTF-8).

But subsequent access to the _same_ URI, i.e.
/site/page.jsp?q=%xx%yy%zz%tt

gives perfect result.

I also tried useBobyEncodingForURI=true and
request.setCharacterEncoding("UTF-8") - nothing is changed.


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message