tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 46069] New: default value of connection_ping_interval is wrong
Date Thu, 23 Oct 2008 04:43:10 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=46069

           Summary: default value of connection_ping_interval is wrong
           Product: Tomcat Connectors
           Version: unspecified
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Common
        AssignedTo: dev@tomcat.apache.org
        ReportedBy: mashmk02@gmail.com


In workers.xml, described as follows. 
-----
If directive connection_ping_interval was not set, the value of ping_timeout *
10 
will be used as connection_ping_interval value.
---

However, default value of connection_ping_interval is ping_timeout * 100.

ex)
Default value of ping_timeout is 10000ms(= 10 seconds).
If set ping_mode=I and not set connection_ping_interval in workers.properties, 
default value of connection_ping_interval is 1000 seconds(= ping_timeout *
100).

-----jk_ajp_common.c
2573:        if ((p->ping_mode & AJP_CPING_INTERVAL) &&
2574:            p->conn_ping_interval == 0)
2575:            p->conn_ping_interval = p->ping_timeout / 10;
---

regards.


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message