tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: [VOTE] Releasing Tomcat Connectors 1.2.27
Date Wed, 29 Oct 2008 10:45:10 GMT
Henri Gomez schrieb:
> Quick note :
> 
> I should use  --enable-api-compatibility on Suse SLES 10 (where Apache
> is still 2.2.3) :
> 
> ./configure --with-apxs=/usr/sbin/apxs2 --enable-api-compatibility

You don't need to, it's more the other way round:

If you build against a very recent 2.2.x httpd, then mod_jk will
activate some minor features, that are only available in those recent
2.2.x versions. If you later try to run it inside 2.2.0-2.2.4 (something
like this), then yo will get a load error, because those older 2.2.x
versions don't have the needed symbols.

If you build against an old 2.2.x like 2.2.3, this can not happen.
Running later with a more recent 2.2.x version is no problem.

So if you have a very recent 2.2.x on your build system but want to
ensure, that the binary will run also with an older 2.2.x version, then
you should add --enable-api-compatibility.

The only feature which varies depending on the switch is the chosen form
of internal version reporting between mod_jk and httpd. Not something
really important to the users.

In short: when compiling against 2.2.3 the switch will not change
anything at all, but when compiling distribution bins it is a good idea
to activate it in general.

Thanks for asking.

Regards,

Rainer

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message