tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: is JDK 1.1 still needed? README say Java5
Date Mon, 11 Aug 2008 09:48:50 GMT
Jim Manico wrote:
> I would say that the era of Java up through 1.3 is dead. Java 1.4 and 
> above is the only thing I see in production anymore.
> 
> - Jim

The 2.5 Servlet spec mandates Java 1.5 so for TC6 and up you are fine.
TC5 needs to run on 1.4 (with the compat package) and TC4 should run on
1.3 although there has been the odd error (by me) in this area but they
do get fixed.

Mark

> 
>> browsing the tomcat trunk, i found org.apache.tomcat.util.collections.*
>>
>> is org.apache.tomcat.util.collections still used? some classes have a 
>> comment  - since this package must also run on JDK 1.1 -
>>
>> there are some Classes wich aren't used any longer? or should not used 
>> (Enumeration replaced by Iterator)
>>
>> some of those (Queue) could be replaced by java.util.concurrent 
>> package i think
>>
>> not used/not visible are 
>> (EmptyEnumeration,MultiMapValuesEnumeration,Queue)
>>
>>
>> ---
>> Jens Kapitza
>>
>>
>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: dev-help@tomcat.apache.org
>>
> 
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message