tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 41564] service. bat does not install tomcat as a service properly on Windows Vista
Date Mon, 21 Jul 2008 23:56:47 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=41564





--- Comment #4 from Bogdan <bdziedzic@atlassian.com>  2008-07-21 16:56:46 PST ---
Vista with User Account Control (UAC) running causes a problem. Vista normally
runs everybody ( including administrators ) in a non-administrative mode.
This provides additional security and makes it more difficult for intruders to
run programs requiring administrative privileges.

Currently, there are two possible workaround that allow to install the windows
service successfully:

The first option - Temporary disable UAC
1. Temporary disable UAC (restart of OS required). It is done from

    * run "msconfig" > tools > disable UAC or
    * Start > Control Panel > User Accounts > Turn User Account Control on or
off
1. Install Tomcat.
      3. Enable UAC - as per 2.
      4. Restart OS

The second option - create a bat file and execute it as admin

   1. Create a bat file that installs the service as per
http://tomcat.apache.org/tomcat-5.5-doc/windows-service-howto.html
   2. Click right button of mouse and select "Run as administrator"

I've tried to initiate the installer with "Run as administrator", although it
failed to install the service.


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message