tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 43327] Socket bind fails on tomcat startup when using apr
Date Sat, 05 Jul 2008 22:40:55 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=43327





--- Comment #15 from Mark Thomas <markt@apache.org>  2008-07-05 15:40:46 PST ---
OK. There are two issues here.

The first is that the APR calls eventually called as a result of Address.info()
and Socket.create() in o.a.t.util.net.AprEndpoint use slightly different logic
to determine whether to create an IPv4 socket or an IPv6 socket. If you have an
IPv6 capable interface that does not have an explicit IPv6 address defined
these functions will assume different IP families.

The second issue is that whilst the first issue could be fixed by using
Address.getInfo().family to specify that the family of the address should be
used to use to create the socket, Address.getInfo() does not convert the
APR_INET and APR_INET6 constants back into the ones defined in Socket (the
constants are different in the Java code and in APR).

So, I have two patches. The first converts the constants back to the Java
defined values and the second uses the family from the address to create the
socket. Patches to follow.


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message