tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 43683] Accessing Servlet while Reloading context gives 404 error
Date Thu, 19 Jun 2008 21:15:03 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=43683





--- Comment #16 from Joe Kislo <joe@k12s.phast.umass.edu>  2008-06-19 14:15:02 PST ---
The Reloading looks like it works well now.  Thanks!

As for case #3... Yes I can still get that to happen.  I thought maybe it was
easier for me to reproduce because my laptop had dual core.  I booted nosmp and
I was still able to get it to happen (infact, I think it may have been easier).

Yes, there is a setting for the 20 second timeout... but it's not hitting that.
 It's pretty much immediately blazing into servicing the request even though
the destroy is in progress.  The Destroy starting you see in my previous
message and the starting servicing come basically at the same time.  I think
the key is to get the request on window 3 in before window 2 is finished
causing the servlet to start.

It doesn't happen every time... And it may be easier to recreate on a slower
machine...  it certainly appears easier to recreate when I replaced the init()
sleep(5000) with a CPU bound loop

Let me know if you can get it to happen... and if not I'll see what I can do
for a better testcase.

Thanks again



-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message