tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henri Gomez" <henri.go...@gmail.com>
Subject Re: Generics and the spec interfaces
Date Tue, 06 May 2008 08:41:26 GMT
I'm for 3 since I wonder if the option 4 follow the specs.

2008/5/6 Mark Thomas <markt@apache.org>:
> All,
>
>  As you have probably noticed I am doing some clean-up of the trunk codebase
> as and when the opportunity arises. So far the clean has identified the odd
> copy/paste error or casting problem as well as (hopefully) making the code
> easier to read. The fixes for the errors are getting ported to 6.0.x.
>
>  I am currently pondering what to do with lines like this:
>  Enumeration e = request.getHeaderNames();
>
>  As I see it the options are:
>  1. Leave it as it is.
>  2. Use
>  Enumeration<?> e = request.getHeaderNames();
>  3. Use
>  Enumeration<String> e = request.getHeaderNames();
>  4. Use
>  Enumeration<String> e = request.getHeaderNames();
>  and modify HttpServletRequest to use generics
>  5. Something else.
>
>  I am leaning towards 4 on the basis that
>  a) This is trunk, not a release branch
>  b) This option generates no warnings
>  c) I assume the spec will start using generics at some point (maybe in
> 3.0?)
>  If modifying the spec interfaces seems like a step too far then 3 would be
> my next choice.
>
>  Thoughts?
>
>  Mark
>
>  ---------------------------------------------------------------------
>  To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
>  For additional commands, e-mail: dev-help@tomcat.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message