tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henri Gomez" <henri.go...@gmail.com>
Subject Problem with tomcat-native
Date Wed, 30 Jan 2008 16:50:57 GMT
Hi to all,

Got this problem on Suse SLES 10 :

Trying to build tomcat-native-1.1.10 with IBM SDK 1.5.0 :

myhost:~/tomcat-native-1.1.10-src/jni/native # ./configure
--with-apr=/usr/bin/apr-1-config --prefix=/usr/
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking for working mkdir -p... yes
Tomcat Native Version: 1.1.10
checking for chosen layout... tcnative
checking for APR... yes
  setting CC to "gcc"
  setting CPP to "gcc -E"
checking for a BSD-compatible install... /usr/bin/install -c
checking for JDK location (please wait)... /opt/ibm-java2-i386-50/
from environment
checking Java platform... checking Java platform...
checking for sablevm... NONE
  adding "-I/opt/ibm-java2-i386-50//include" to TCNATIVE_PRIV_INCLUDES
checking os_type directory... Cannot find jni_md.h in /opt/ibm-java2-i386-50/
configure: error: You should retry --with-os-type=SUBDIR
erable6bis:~/tomcat-native-1.1.10-src/jni/native # ./configure
--with-apr=/usr/bin/apr-1-config --prefix=/usr/

Normal, on IBM JDK 1.5.0 we have no jni_md.h:

-rw-r--r-- 1 root root  9573 Oct 25 19:04 jawt.h
-rw-r--r-- 1 root root  2135 Oct 25 19:04 jawt_md.h
-rw-r--r-- 1 root root  6597 Oct 25 19:04 jdwpTransport.h
-rw-r--r-- 1 root root 61063 Oct 25 19:04 jni.h
-rw-r--r-- 1 root root  1256 Oct 25 19:04 jniport.h
-rw-r--r-- 1 root root 13377 Oct 25 19:04 jvmpi.h
-rw-r--r-- 1 root root   529 Oct 25 19:04 jvmras.h
-rw-r--r-- 1 root root  5421 Oct 25 19:04 jvmri.h
-rw-r--r-- 1 root root 53732 Oct 25 19:04 jvmti.h


with tomcat-native 1.1.12 :

myhost:~/tomcat-native-1.1.12-src/jni/native # ./configure
--with-apr=/usr/bin/apr-1-config --prefix=/usr/
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking for working mkdir -p... yes
Tomcat Native Version: 1.1.12
checking for chosen layout... tcnative
checking for APR... yes
  setting CC to "gcc"
  setting CPP to "gcc -E"
checking for a BSD-compatible install... /usr/bin/install -c
checking for JDK location (please wait)... /opt/ibm-java2-i386-50 from
environment
checking Java platform... checking Java platform...
checking for sablevm... NONE
Using J9VM: J9VM - 20071004_14218_lHdSMR
  adding "-I/opt/ibm-java2-i386-50/include" to TCNATIVE_PRIV_INCLUDES
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for OpenSSL library... not found
  setting TCNATIVE_LIBS to ""
  setting TCNATIVE_LIBS to " /usr/lib/libapr-1.la -lrt -lcrypt  -lpthread -ldl"
  setting TCNATIVE_LDFLAGS to ""
./configure: line 4315: APR_BUILD_DIR: command not found
./configure: line 4316: APR_INCLUDES: command not found
./configure: line 4317: APR_LIBS: command not found
./configure: line 4318: APR_LIB_TARGET: command not found
./configure: line 4319: APR_SO_EXT: command not found
./configure: line 4320: BASH: command not found
./configure: line 4321: BASH_ARGC: command not found
./configure: line 4322: BASH_ARGV: command not found
./configure: line 4323: BASH_LINENO: command not found
./configure: line 4324: BASH_SOURCE: command not found
./configure: line 4325: BASH_VERSINFO: command not found
./configure: line 4326: BASH_VERSION: command not found
./configure: line 4327: CC: command not found
./configure: line 4328: CFLAGS: command not found
./configure: line 4329: COLORTERM: command not found
./configure: line 4330: CPP: command not found
./configure: line 4331: CPU: command not found
./configure: line 4332: CSHEDIT: command not found
./configure: line 4333: CVS_RSH: command not found
./configure: line 4334: DIRSTACK: command not found
./configure: line 4335: DUALCASE: command not found
./configure: line 4336: ECHO_C: command not found
./configure: line 4337: ECHO_N: command not found
./configure: line 4338: ECHO_T: command not found
./configure: line 4339: EUID: command not found
./configure: line 4340: EXEEXT: command not found
./configure: line 4341: EXTRA_OS_LINK: command not found
./configure: line 4342: FROM_HEADER: command not found
./configure: line 4343: GCC: command not found
./configure: line 4344: GNOME2_PATH: command not found
./configure: line 4345: GROFF_NO_SGR: command not found
./configure: line 4346: GROUPS: command not found
./configure: line 4347: GTK_PATH: command not found
./configure: line 4348: G_BROKEN_FILENAMES: command not found
./configure: line 4349: HISTSIZE: command not found
./configure: line 4350: HOME: command not found
./configure: line 4351: HOST: command not found
./configure: line 4352: HOSTNAME: command not found
./configure: line 4353: HOSTTYPE: command not found
./configure: line 4354: IFS: command not found
./configure: line 4355: INCLUDE_OUTPUTS: command not found
./configure: line 4356: INCLUDE_RULES: command not found
./configure: line 4357: INFODIR: command not found
./configure: line 4358: INFOPATH: command not found
./configure: line 4359: INPUTRC: command not found
./configure: line 4360: INSTALL: command not found
./configure: line 4361: INSTALL_DATA: command not found
./configure: line 4362: INSTALL_PROGRAM: command not found
./configure: line 4363: INSTALL_SCRIPT: command not found
./configure: line 4364: J9VM: command not found
./configure: line 4365: JAVA: command not found
./configure: line 4366: JAVA_BINDIR: command not found
./configure: line 4367: JAVA_HOME: command not found
./configure: line 4368: JAVA_HOME_ENV: command not found
./configure: line 4369: JAVA_INC: command not found
./configure: line 4370: JAVA_PLATFORM: command not found
./configure: line 4371: JAVA_ROOT: command not found
./configure: line 4372: JRE_HOME: command not found
./configure: line 4373: LANG: command not found
./configure: line 4374: LANGUAGE: command not found
./configure: line 4375: LAYOUT: command not found
./configure: line 4376: LC_ADDRESS: command not found
./configure: line 4377: LC_ALL: command not found
./configure: line 4378: LC_COLLATE: command not found
./configure: line 4379: LC_CTYPE: command not found
./configure: line 4380: LC_IDENTIFICATION: command not found
./configure: line 4381: LC_MEASUREMENT: command not found
./configure: line 4382: LC_MESSAGES: command not found
./configure: line 4383: LC_MONETARY: command not found
./configure: line 4384: LC_NAME: command not found
./configure: line 4385: LC_NUMERIC: command not found
./configure: line 4386: LC_PAPER: command not found
./configure: line 4387: LC_TELEPHONE: command not found
./configure: line 4388: LC_TIME: command not found
./configure: line 4389: LESS: command not found
./configure: line 4390: LESSCLOSE: command not found
./configure: line 4391: LESSKEY: command not found
./configure: line 4392: LESSOPEN: command not found
./configure: line 4393: LESS_ADVANCED_PREPROCESSOR: command not found
./configure: line 4394: LIBOBJS: command not found
./configure: line 4395: LINENO: command not found
./configure: line 4396: LOGNAME: command not found
./configure: line 4397: LS_COLORS: command not found
./configure: line 4398: LS_OPTIONS: command not found
./configure: line 4399: MACHTYPE: command not found
./configure: line 4400: MAKEFILES: command not found
./configure: line 4401: MAKEFLAGS: command not found
./configure: line 4402: MANPATH: command not found
./configure: line 4403: MFLAGS: command not found
./configure: line 4404: MINICOM: command not found
./configure: line 4405: MORE: command not found
./configure: line 4406: NEED_JNI_MD: command not found
./configure: line 4407: NNTPSERVER: command not found
./configure: line 4408: OBJEXT: command not found
./configure: line 4409: OPENSSL_WARNING: command not found
./configure: line 4410: OPTERR: command not found
./configure: line 4411: OPTIND: command not found
./configure: line 4412: OSTYPE: command not found
./configure: line 4413: PACKAGE_BUGREPORT: command not found
./configure: line 4414: PACKAGE_NAME: command not found
./configure: line 4415: PACKAGE_STRING: command not found
./configure: line 4416: PACKAGE_TARNAME: command not found
./configure: line 4417: PACKAGE_VERSION: command not found
./configure: line 4418: PAGER: command not found
./configure: line 4419: PATH: command not found
./configure: line 4420: PATH_SEPARATOR: command not found
./configure: line 4421: PIPESTATUS: command not found
./configure: line 4422: PKG_CONFIG_PATH: command not found
./configure: line 4423: POSIXLY_CORRECT: command not found
./configure: line 4424: PPID: command not found
./configure: line 4425: PROFILEREAD: command not found
./configure: line 4426: PS1: command not found
./configure: line 4427: PS2: command not found
./configure: line 4428: PS4: command not found
./configure: line 4429: PWD: command not found
./configure: line 4430: PYTHONSTARTUP: command not found
./configure: line 4431: QT_SYSTEM_DIR: command not found
./configure: line 4432: SABLEVM: command not found
./configure: line 4433: SHELL: command not found
./configure: line 4434: SHELLOPTS: command not found
./configure: line 4435: SHLVL: command not found
./configure: line 4436: SSH_CLIENT: command not found
./configure: line 4437: SSH_CONNECTION: command not found
./configure: line 4438: SSH_TTY: command not found
./configure: line 4439: TCNATIVE_DOTTED_VERSION: command not found
./configure: line 4440: TCNATIVE_INCLUDES: command not found
./configure: line 4441: TCNATIVE_LDFLAGS: command not found
./configure: line 4442: TCNATIVE_LIBNAME: command not found
./configure: line 4443: TCNATIVE_LIBS: command not found
./configure: line 4444: TCNATIVE_LIBTOOL_VERSION: command not found
./configure: line 4445: TCNATIVE_MAJOR_VERSION: command not found
./configure: line 4446: TCNATIVE_PRIV_INCLUDES: command not found
./configure: line 4447: TCN_CONFIG_LOCATION: command not found
./configure: line 4448: TCN_OPENSSL_INC: command not found
./configure: line 4449: TERM: command not found
./configure: line 4450: TEST_X: command not found
./configure: line 4451: TEXINPUTS: command not found
./configure: line 4452: UID: command not found
./configure: line 4453: USER: command not found
./configure: line 4454: USE_OPENSSL: command not found
./configure: line 4455: WINDOWMANAGER: command not found
./configure: line 4456: XCURSOR_THEME: command not found
./configure: line 4457: XDG_CONFIG_DIRS: command not found
./configure: line 4458: XDG_DATA_DIRS: command not found
./configure: line 4459: XKEYSYMDB: command not found
./configure: line 4460: XNLSPATH: command not found
./configure: line 4461: _: command not found
./configure: line 4462: abs_builddir: command not found
./configure: line 4463: abs_srcdir: command not found
./configure: line 4464: ac_abs_confdir: command not found
./configure: line 4465: ac_arg: command not found
./configure: line 4466: ac_aux_dir: command not found
./configure: line 4467: ac_build_alias: command not found
./configure: line 4468: ac_c_werror_flag: command not found
./configure: line 4469: ac_cache_corrupted: command not found
./configure: line 4470: ac_clean_files: command not found
./configure: line 4471: ac_clean_files_save: command not found
./configure: line 4472: ac_compile: command not found
./configure: line 4473: ac_compiler: command not found
./configure: line 4474: ac_compiler_gnu: command not found
./configure: line 4475: ac_confdir: command not found
./configure: line 4476: ac_config_commands: command not found
./configure: line 4477: ac_config_files: command not found
./configure: line 4478: ac_config_guess: command not found
./configure: line 4479: ac_config_libobj_dir: command not found
./configure: line 4480: ac_config_sub: command not found
./configure: line 4481: ac_configure: command not found
./configure: line 4482: ac_configure_args: command not found
./configure: line 4483: ac_cpp: command not found
./configure: line 4484: ac_ct_CC: command not found
./configure: line 4485: ac_cv_build: command not found
./configure: line 4486: ac_cv_c_compiler_gnu: command not found
./configure: line 4487: ac_cv_env_CC_set: command not found


Any configure guru around ?

Regards

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message