tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Hanik - Dev Lists <devli...@hanik.com>
Subject Re: slight gotcha with tomcat 6.0 cluster startup with already running tomcat 5 cluster on the network
Date Thu, 31 Jan 2008 21:19:16 GMT
thanks for the feedback, we can add in a message, that notifies the user 
that we are receiving invalid multicast packets and that there is 
probably some other piece of software broadcasting on our channel

Filip

Haroon Rafique wrote:
> Hi there,
>
> I ran into something today which might help someone out later so I'm 
> posting this here. On my network, I didn't know that I had an old 
> install of tomcat 5.5.23 running with <Cluster> config enabled. I 
> installed tomcat 6.0.14 on a new machine with <Cluster> config enabled 
> (simple 1-liner in 6.0.x). Upon startup of the 6.0.14 tomcat I got a 
> less than helpful error regarding the cluster.
>
> Here's the relevant log entries:
>
> Jan 31, 2008 2:53:13 PM org.apache.catalina.ha.tcp.SimpleTcpCluster start
> INFO: Cluster is about to start
> Jan 31, 2008 2:53:13 PM 
> org.apache.catalina.tribes.transport.ReceiverBase bind
> INFO: Receiver Server Socket bound to:/my.ip.address.here:4000
> Jan 31, 2008 2:53:13 PM 
> org.apache.catalina.tribes.membership.McastServiceImpl setupSocket
> INFO: Setting cluster mcast soTimeout to 500
> Jan 31, 2008 2:53:13 PM 
> org.apache.catalina.tribes.membership.McastServiceImpl waitForMembers
> INFO: Sleeping for 1000 milliseconds to establish cluster membership, 
> start level:4
>
> So, far so good. Then came this bit:
>
> Jan 31, 2008 2:53:13 PM 
> org.apache.catalina.tribes.membership.McastServiceImpl$ReceiverThread run
> WARNING: Error receiving mcast package. Sleeping 500ms
> java.lang.IllegalArgumentException: Invalid package, should start 
> with:{84, 82, 73, 66, 69, 83, 45, 66}
>         at 
> org.apache.catalina.tribes.membership.MemberImpl.getMember(MemberImpl.java:317) 
>
>         at 
> org.apache.catalina.tribes.membership.MemberImpl.getMember(MemberImpl.java:293) 
>
>         at 
> org.apache.catalina.tribes.membership.MemberImpl.getMember(MemberImpl.java:398) 
>
>         at 
> org.apache.catalina.tribes.membership.McastServiceImpl.receive(McastServiceImpl.java:284)

>
>         at 
> org.apache.catalina.tribes.membership.McastServiceImpl$ReceiverThread.run(McastServiceImpl.java:366)

>
>
> which didn't tell me whole lot. This exception was repeated at a 
> frequency of almost 1 per second. To resolve this, it took me a few 
> hours or so to figure out that the old tomcat 5.5 was still running 
> with <Cluster> enabled which was the cause of this.
>
> Could something be done to catch this situation and display a more 
> helpful message?
>
> Thanks,
> -- 
> Haroon Rafique
> <haroon.rafique@utoronto.ca>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: dev-help@tomcat.apache.org
>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message